Perrypedia:Beobachtete Fehler

Aus Perrypedia
Wechseln zu: Navigation, Suche
Google translator: Translation from German to English.
Google translator: Překlad z němčiny do češtiny.
Google translator: Vertaling van het Duits naar het Nederlands.
Google translator: ドイツ語から日本語への翻訳
Google translator: Traduction de l'allemand vers le français.
Google translator: Tradução do alemão para o português.

Um diese Seite übersichtlich zu gestalten, bitte

  • neue Beiträge/ Fragen oben und nach diesem Textkasten einfügen.
  • jedem neuen Beitrag eine Überschrift geben (z.B: == Diskussionsthema ==).
  • mit zwei Bindestrichen und vier Tilden (--~~~~) unterschreiben.

Archivierte Beiträge

2005–2006 | 2007–2008 | 2009–2010 | 2011–2013 | 2014–2016 | 2017–2019 | ...


DB-Fehler

@Klenzy&Admins: Ich habe heute 12.9.2020 14:33 einen Datenbankfehler erhalten. Ich wollte die Datei:PR0545Illu_2.gif nach Datei:PR0545Illu_3.gif (ohne Weiterleitung verschieben). Dabei erhielt ich einen ersten Ausnahmefehler mit dem Hinweis, dass es diese Datei offensichtlich schon gäbe. Nachdem ich alle Links auf die Datei manuell entfernt hatte versuchte ich es ein zweites Mal. Dabei erhielt ich folgenden Fehler Datei:DBFehler 2020-09-12 1433.jpg. Vielleicht handelt es sich wieder um eine früher nicht komplett richtig angelegte Datei ohne passende Beschreibung. Benötige Ratschlag --Norman (Diskussion) 14:46, 12. Sep. 2020 (CEST)

Zwischenzeitlich habe ich festgestellt, dass die Datei Datei:PR0545Illu_3.gif seit 2015 angelegt ist aber im Wiki erst noch ERSTELLT werden muss. Wie geschrieben ich bin auf solche Fälle schon ca. 10 mal gestoßen und kann mir nun helfen. Insofern nur die Frage, kann man solche inkonsitenten Dateien irgendwie per Chek-Programm o.ä. ermitteln? --Norman (Diskussion) 14:54, 12. Sep. 2020 (CEST)
Ich glaube, da gibt es was. Versuche ich nachher. --Klenzy (Diskussion) 15:16, 12. Sep. 2020 (CEST)
Im ersten Lauf hat das Prüfprogramm 3 Dateien gefunden: A200_1.jpg, MB_VAIA_MYR.png und eben PR0545Illu_3.gif.
Es gibt verschiedene Reparaturskripte, die auch irgendwas machen, aber erfolgreich war das nur bei dem Atlan-Cover. Die anderen beiden bleiben fehlerhaft. Wenn Du das selbst beheben kannst, dann mach's; ansonsten kann ich anbieten, den betreffenden Satz aus der Datenbank zu löschen.
Ich vermute, die Wikiskripte sind chancenlos, wenn die Datei im Dateisystem vorhanden ist aber in der Datenbank fehlt. Es gibt zwar ein Skript für den Abgleich Datenbank -> Dateisystem, aber nicht umgekehrt. Daher fällt das Problem nicht auf, solange bis man eine Datei auf einen solchen Namen verschieben will, der in der DB fehlt aber in Wirklichkeit bereits vorhanden ist. --Klenzy (Diskussion) 17:03, 12. Sep. 2020 (CEST)
Das Problem mit der Illu ist nun behoben. Danke für deine Hilfe und Infos. Bei MB_VAIA_MYR.png schaue ich mal was ich machen kann. --Norman (Diskussion) 18:01, 12. Sep. 2020 (CEST)

Verbindungsprobleme

Seit einiger Zeit fallen mir ganz vereinzelte Verbindungsabbrüche auf. Der Browser meldet dann "Verbindung zum Server fehlgeschlagen". Wenn es mal auftritt, dann stets zwischen 15:00 und 20:00 Uhr und nach zwei oder drei Versuchen (30-90 Sekunden) funktioniert alles wieder. Norman hat mir neulich ganz ähnliches gemeldet. In den Serverlogs ist nichts zu sehen. Ich habe auf unserem Testserver, den wir im Moment ja noch haben, ein kleines Monitoringskript eingerichtet. In der nachfolgenden Tabelle möchte ich vier Wochen lang Daten sammeln, damit wir evtl. bei unserem Provider anklopfen können. --Klenzy (Diskussion) 16:51, 3. Mai 2020 (CEST)

Ist mir bei der Perrypedia noch nicht aufgefallen, aber in den letzten Wochen bei Sueddeutsche.de, ebay.com und imdb.com. Ich schob es bisher auf meinen Rechner oder eine Überlastung der örtlichen Infrastruktur einer Millionenstadt. --Thinman (Diskussion) 16:25, 4. Mai 2020 (CEST)
Datum Uhrzeit Dauer Benutzer
03.05. 16:41 ca. 30 Sek. --Klenzy (Diskussion) 16:51, 3. Mai 2020 (CEST)
14.05. 16:31 ca. 30 Sek. --Klenzy (Diskussion) 16:32, 14. Mai 2020 (CEST)
03.07. 16:20 ca. 20 Sec. --W. Butz (Diskussion) 16:24, 3. Jul. 2020 (CEST)

Probleme beim Finden der Seite

Hi, ich wollte einmal fragen ob es im Momemt Probleme mit der Seite gibt? Ich hatte am Abend mehrmals das Problem das die Seite nicht gefunden wurde bzw. es technische Probleme beim herstellen der Seite gab. --Tek (Diskussion) 22:25, 30. Mär 2020 (CEST)

Kann ich bestätigen, auch für mich war der Server eine zeitlang nicht erreichbar. --GolfSierra (Diskussion) 08:00, 31. Mär 2020 (CEST)
Bitte um Entschuldigung. Gestern abend habe ich einen zusätzlichen Backup der Datenbank laufen lassen. Dabei ist die MySQL-Datenbank stehengeblieben. Nicht abgestürzt, einfach stehengeblieben. Ursachenforschung läuft noch. Da ich einige Zeit nicht am Platz war, wusste ich nicht, ob das Problem 2 Minuten, 20 Minuten oder 2 Stunden lang bestand und konnte mich nicht entscheiden, euch zu informieren. --Klenzy (Diskussion) 08:43, 31. Mär 2020 (CEST)
Alles Gut, Klenzy, das erklärt es (für uns). Wir machen uns halt Sorgen, wenn unser "Baby" mal nicht wie sonst reagiert. --GolfSierra (Diskussion) 11:28, 31. Mär 2020 (CEST)
Ja genau, wir hatten uns nur Gedanken gemacht. Viele Dank für deine Arbeit. Ich finde das echt super von dir, wie du dich um die Pflege da Datenbank und die Technik kümmerst. Hut ab. --Tek (Diskussion) 11:45, 31. Mär 2020 (CEST)
I'll do my very best ;-) --Klenzy (Diskussion) 13:07, 31. Mär 2020 (CEST)

Darstellungsproblem mit langen Artikelnamen

Nur ein kleines kosmetisches Problem, bei ungewöhnlich langen Artikeln wie bei Institutionen des Großen Imperiums, ein Wegweiser für Karrierebewusste überdecken bei mir (Firefox 74 unter Windows 7) die Übersetzungsfahnen den letzten Teil des Namens. --Thinman (Diskussion) 20:42, 12. Mär 2020 (CET)

Das Problem ist bekannt, kann aber nur durch ein grundlegend geändertes Design des Übersetzungsangebots gelöst werden. Das ist nicht leicht. --JoKaene 20:56, 12. Mär 2020 (CET)
Theoretisch müsste es möglich sein, den Ausgabebereich für die Überschrift so zu verschmälern, dass bei Bedarf ein Zeilenumbruch eingefügt wird. Das übersteigt derzeit mein Wissen und meine Fähigkeiten. Vielleicht, wenn ich einmal viel Zeit habe ... --Klenzy (Diskussion) 09:48, 13. Mär 2020 (CET)

Wichtiger Hinweis für T-Online-Nutzer

Wir haben seit dem 17.12.2019 ein Problem mit dem Mailversand. Betroffen sind (einige/mehrere/alle?) Benutzer mit Mailadressen @t-online.de. Leider ist es mir erst heute aufgefallen. Ich bekomme zwar jedesmal eine Kopie der nicht zugestellten Mails mit dem Fehlercode, diesen habe ich aber wochenlang nicht mehr angeschaut, weil es eine Flut von unzustellbaren Mails von der Beobachtungsliste an einen Benutzer gab, der schon lange nicht mehr aktiv ist. Heute habe ich per Zufall gesehen, dass wir mit Fehlercode 554 abgewiesen werden. Das bedeutet, dass wir wahrscheinlich bei der Telekom auf der Blacklist stehen, typischerweise passiert so etwas bei einem Massenversand von Spammails. Ich werde versuchen, ob ich dort jemanden finden kann, der uns weiterhilft. --Klenzy (Diskussion) 16:40, 4. Feb. 2020 (CET)

Es hängt mutmaßlich mit unserem Serverwechsel zusammen. Die Telekom hat mir geschrieben, dass das Problem binnen der nächsten 24 Stunden behoben wird. Meine Vermutung ist, dass der vorherige Inhaber der IP auf der Blacklist gelandet ist. --Klenzy (Diskussion) 10:47, 5. Feb. 2020 (CET)
Sollte inzwischen funktionieren. Gibt's jemand, mit dem wir das testen können? --Klenzy (Diskussion) 14:31, 9. Feb. 2020 (CET)
Ja. Ich habe soeben wieder auf meine T-Online-Adresse geändert. Mails kamen an. --Norman (Diskussion) 16:25, 9. Feb. 2020 (CET)
Na sowas. Dankeschön! --Klenzy (Diskussion) 17:31, 9. Feb. 2020 (CET)

Rechte für Bots

Ich betreue Benutzer:SyntronsBot und wollte den Bot mit Band 3050 mal wieder ausführen. Es läuft gut bis zu dem Punkt, wo der Bot versucht, die Seiten in der Perrypedia zu updaten. Dann erhalte ich eine Fehlermeldung. Kann es sein, dass mit dem Wechsel des Servers / der Neuinstallation die entsprechenden Rechte für Bots nicht gesetzt wurden? Anbei die gekürzte Ausgabe vom Bot mit der entsprechenden Antwort zu dem Versuch eine Seite zu bearbeiten (= permissiondenied):

Feb 04 10:45:26 console [info] Update Perrypedia page 'Perry_Rhodan-Glossar_A' ...
Feb 04 10:45:26 console [debug] [PerrypediaGlossarBot:PP_request] start
Feb 04 10:45:26 console [debug] URL:  'https://www.perrypedia.de/mediawiki/api.php'
Feb 04 10:45:26 console [debug] GET:  'format' => 'json'
Feb 04 10:45:26 console [debug] POST: 'action' => 'edit'
Feb 04 10:45:26 console [debug] POST: 'text' => '{{Navigationsle...PPDefaultsort}}'
Feb 04 10:45:26 console [debug] POST: 'md5' => '3079057ad13e871ece0bbf503760aabe'
Feb 04 10:45:26 console [debug] POST: 'summary' => 'SyntronsBot Upd...T10:45:26+00:00'
Feb 04 10:45:26 console [debug] POST: 'bot' => '1'
Feb 04 10:45:26 console [debug] POST: 'nocreate' => '1'
Feb 04 10:45:26 console [debug] POST: 'title' => 'Perry_Rhodan-Glossar_A'
Feb 04 10:45:26 console [debug] POST: 'token' => '+\'
Feb 04 10:45:26 console [debug] POST: 'format' => 'json'
Feb 04 10:45:27 console [debug] URL 'https://www.perrypedia.de/mediawiki/api.php' - success
Feb 04 10:45:27 console [debug] request result (json format): Array
(
    [error] => Array
        (
            [code] => permissiondenied
            [info] => The action you have requested is limited to users in the group: [[Perrypedia:Benutzer|Benutzer]].
            [*] => See https://www.perrypedia.de/mediawiki/api.php for API usage. Subscribe to the mediawiki-api-announce mailing list at <https://lists.wikimedia.org/mailman/listinfo/mediawiki-api-announce> for notice of API deprecations and breaking changes.
        )

)

Feb 04 10:45:27 console [debug] [PerrypediaGlossarBot:PP_request] end
Feb 04 10:45:27 console [error] Error updating page 'Perry_Rhodan-Glossar_A'
Feb 04 10:45:27 console [error] Exception: Error updating page 'Perry_Rhodan-Glossar_A'

Ich habe da im Moment keine weitere Analyse betrieben, da es unter Umständen eine einfache Einstellung in der Konfiguration ist. --Syntron (Diskussion) 11:50, 4. Feb. 2020 (CET)

Die Fehlermeldung besagt, dass Du nicht angemeldet bist: »The action you have requested is limited to users in the group: Benutzer.« Könnte es das sein? --Klenzy (Diskussion) 12:08, 4. Feb. 2020 (CET)
Muss ich testen - bisher hat sich der Bot ordnungsgemäß angemeldet; an dem entsprechendem Code bzw. den Logindaten habe ich nichts geändert. --Syntron (Diskussion) 12:16, 4. Feb. 2020 (CET)
OK, daran lag es - und die entsprechende Fehlermeldung gab es auch im Log! Nur habe ich sie nicht gelesen, weil sie schon nicht mehr auf dem Bildschirm zu sehen war ... Allerdings habe ich die Daten nicht geändert (Account: SyntronsBot mit dem entsprechenden Passwort). Leider hat SyntronsBot keine Email hinterlegt, so dass ich das Passwort nicht über 'Passwort vergessen' neu setzen kann. Ist dies bei Bots überhaut möglich? --Syntron (Diskussion) 12:29, 4. Feb. 2020 (CET)
Durchlauf als Syntron war erfolgreich. Wurde das Passwort möglicherweise durch Änderungen am Server modifiziert? Könntest du ein neues Passwort vergeben und mir per Email schicken (syntron [@] web.de)? Ich würde dann als erstes dem Bot für solche Fälle eine Email verpassen und ihn dann auch noch einmal testen. --Syntron (Diskussion) 13:45, 4. Feb. 2020 (CET)
Nein, ein neues Passwort können wir nicht vergeben, weder die Admins noch ich als Sysadmin. Kein Hintertürchen, auch nicht mit SQL.
Was ich aber per SQL ändern kann, ist die Mailadresse und die habe ich soeben eingetragen, sodass Du jetzt ein neues Passwort anfordern kannst. --Klenzy (Diskussion) 16:27, 4. Feb. 2020 (CET)
Verstanden und auch logisch; neues Passwort ist nun per Mail unterwegs. Ich werde das Ergebnis hier vermerken. --Syntron (Diskussion) 22:59, 4. Feb. 2020 (CET)
Funktioniert wieder - Danke! Wobei die Ursache im Dunkeln bleiben wird; gab es Rückmeldungen von den anderen Bots? --Syntron (Diskussion) 23:05, 4. Feb. 2020 (CET)
Sonst ist mir nichts bekannt. Der Fall bleibt dubios. --Klenzy (Diskussion) 10:45, 5. Feb. 2020 (CET)

Fehler bei der SMW-Portalgenierung

Offen

  • Unter selten auftretenden Umständen wird ein Portalabschnitt ohne Einträge leer angezeigt, anstatt den den Platzhalter "* ..." zu zeigen. Dies beeinträchtigt die Funktionalität der Portalseiten aber nicht. Es ist nur ... unschön. --Lars Jürgenson (Diskussion) 13:41, 29. Jan. 2020 (CET)

Repariert

  • Mit Zahlen beginnende Personennamen / etc. werden nicht unter "0-9" zusammengefasst. --Lars Jürgenson (Diskussion) 12:26, 1. Feb. 2020 (CET)
  • In der Personensortierung (und nur dort) wird fälschlicherweise das Apostroph nicht ignoriert. --Lars Jürgenson (Diskussion) 13:25, 1. Feb. 2020 (CET)
  • Ist ein Eintrag in der Todo-List für eine Kategorie vorhanden und wird der Artikel dann angelegt, taucht im Portal der Begriff dann in dieser Kategorie manchmal doppelt auf. Nach meiner Beobachtung passiert dies nur, wenn Leerzeichen im Artikelnamen enthalten sind und keine Umstellung von Vor- und Nachnamen erfolgt.
Beispiele:
  • Endlose Nacht im Portal Arkon unter Andere Schauplätze
  • Die Imperatoren im Portal Epetran unter Personen, Anmerkung: Ich habe sie dort bereits in der Todo-Liste auskommentiert.
--Hb059 (Diskussion) 07:37, 8. Feb. 2020 (CET)
Seltsam. Offenbar ist das ein Caching-Problem mit der Todoseite: Wenn man diese (irgendwo) bearbeitet, verschwindet der "doppelte" Eintrag. Seltsam ist, dass das nur Titel mit Leerzeichen betrifft. Es scheint, als ob das Anlegen einer ANDEREN Seite wie gewohnt dafür sorgt, dass die Todoseite "refresht" wird (weil sie auf die neue Seite verlinkt), aber dieser Mechanismus nicht greift, wenn der Seitenname ein Leerzeichen enthält ... oder die Seite wird "refresht" aber der Eintrag in den SMW-Tabellen wird nicht gelöscht.
Da muss ich mal genauer schauen. Leider kann ich das Problem im Testwiki nicht reproduzieren (was für die Caching-These spricht).
Erinnerst du dich, ob der Eintrag auf der Todoliste (vor dem Auskommentieren) grün hinterlegt war? Das würde einen Hinweis liefern, dass das caching-Problem auf SMW-Seite (und nicht im normalen Mediawiki) liegt.
--Lars Jürgenson (Diskussion) 10:18, 8. Feb. 2020 (CET)
Ja, die waren eindeutig grün. --Hb059 (Diskussion) 10:21, 8. Feb. 2020 (CET)
Dann sind wir ein Stück weiter ... ich habe jetzt mal testweise in die Todoseiten von "Arkon", "Epetran" und "Protektorat Erde" ein explizites __NOCACHE__ eingefügt. Halte bitte mal ein Auge drauf und schau, ob das Problem immer noch auftritt.--Lars Jürgenson (Diskussion) 10:39, 8. Feb. 2020 (CET)
Der __NOCACHE__ Eintrag scheint zu wirken. Damit funktioniert es auf all den von dir geänderten Portalen. Nur auf dem noch nicht geänderten Portal Das Große Imperium tritt der Fehler noch auf. --Hb059 (Diskussion) 00:48, 10. Feb. 2020 (CET)
Ich habe das jetzt mal überall gesetzt. Die Absicht war sowieso, die Todoseiten vom Caching auszunehmen. Das hatte ich über eine der Vorlagen gemacht. Aber entweder funktioniert das nicht oder (wahrscheinlicher): Es funktioniert, aber SMW "sieht" das nocache nicht und cached deshalb Dinge, die es nicht cachen sollte.
Sag' bescheid, falls das Problem trotzdem nochmal auftritt. --Lars Jürgenson (Diskussion) 10:25, 11. Feb. 2020 (CET)

Atom-Feed

Ich hab' den Link zum Atom-Feed zwar ewig nicht betätigt, aber die erscheinende Seite wird doch sicher falsch dargestellt!?! --JoKaene 22:37, 30. Jan. 2020 (CET)

Zwischenstand: Dieselbe Darstellung gibt's auf de.wikipedia.org, en.wikipedia.org und www.mediawiki.org. Scheint also ein weit verbreitetes Phänomen zu sein. Und natürlich: ja, stimmt so sicher nicht. --Klenzy (Diskussion) 19:03, 31. Jan. 2020 (CET)
Nur zur Info!
Mit PC und FF erhalte ich eine sehr lange Seite mit endlosem Text (keinerlei Leerzeichen). Mit Tablet und Chrome erhalte ich zumindest eine sauber formatierte html-code-Seite (document tree). Dazu gibt mir Chrome aber auch die Fehlermeldung »This XML-File does not appear to have any style Information associatet with it« aus.
Aber wenn's eh nirgendwo funktioniert, gibt's hier wohl keinen Handlungsbedarf. Ich bin ja auch nur zufällig drauf gestoßen. --JoKaene 19:39, 31. Jan. 2020 (CET)
Firefox liefert Feeds seit ...xyz... nur noch unformatiert: [1]
Dafür gibt es aber neue AddIns, die den Job machen. Ich habe vier der am häufigsten installierten Feedreader ausprobiert: "Brief" [2] und "Feed Preview" [3] kann ich empfehlen, eingeschränkt tauglich sind "RSSPreview" [4] und "Feedbro" [5].
Für Chrome reicht's heute nicht mehr. --Klenzy (Diskussion) 22:54, 1. Feb. 2020 (CET)
Bei Chrome hat das - angeblich - noch nie funktioniert: [6]
Diese Extension soll's richten: [7]; funktioniert auch irgendwie; ich komme jedoch mit der Bedienung nicht zurecht. --Klenzy (Diskussion) 14:38, 2. Feb. 2020 (CET)
Bei Opera funktioniert es ohne Extension, aber nicht durch Klick auf den Atom-Link aus der Sidebar; sondern man muss den Atom-Link https://www.perrypedia.de/mediawiki/api.php?hidebots=1&urlversion=1&days=7&limit=50&action=feedrecentchanges&feedformat=atom selber in den Newsreader einfügen: Opera-Menü -> Nachrichten -> Meine Quellen -> Quellen hinzufügen. Das Ergebnis ist, ähnlich wie beim Chrome, suboptimal. --Klenzy (Diskussion) 14:48, 2. Feb. 2020 (CET)

Übersetzung von Diskussionsseiten

Laut der Seite Hilfe:Übersetzung sollte auch bei Diskussionsseiten die Übersetzungsflaggen eingeblendet werden. Dem ist aber nicht so. Ich weiss jetzt nicht, ob das ein Fehler, oder Absicht ist. Auf jeden Fall muss entweder, die Hilfeseite hierzu angpasst werden, oder bei den Disskussionsseiten müssen die Flaggen aktiviert werden. Bis zur Klärung kann man sich behelfen indem man auf die eigentliche Seite geht, die Übersetzung anklickt und dann wieder auf die Disskussionsseite zurück geht. Siehe auch hier Hilfe Diskussion:Übersetzung#Aktueller Translator-Status. --Norman (Diskussion) 13:15, 20. Jan. 2020 (CET)

Das habe ich anscheinend zwar geplant, aber nie gemacht.
Für die Diskussionsseiten im Hauptnamensraum habe ich das jetzt mal aktiviert, aber da stimmt die Positionierung der Flaggen nicht. Das kann ich mir erst später in Ruhe anschauen. --Klenzy (Diskussion) 13:55, 20. Jan. 2020 (CET)
So, jetzt stimmt die Hilfeseite! Die Übersetzungsflaggen sind auch auf den Diskussionsseiten für Hauptnamensraum, Perrypedia, Hilfe und Kategorien und sie müssten auch in allen Skins korrekt positioniert sein. Getestet habe ich aktuell nur Vector.
Hilfe Diskussion:Übersetzung#Aktueller Translator-Status schaffe ich heute nicht mehr. --Klenzy (Diskussion) 23:50, 20. Jan. 2020 (CET)

Handbuch  →   Organisatorische Seiten